無法配置SmarterMail作為Plesk中的郵件服務怎么辦?
更新時間: 2023-07-03 11:25:02
適用版本:
Plesk for Windows
問題
1. 無法通過 工具與設置 > 服務器組件 配置 SmarterMail 服務:在指定正確的驗證憑據(jù)后,沒有出現(xiàn)錯誤,但是服務仍顯示為'未配置'。
2. 啟用 Plesk 后端調(diào)試時,在 %plesk_dir%admin\logs\plesklog_debug.log 中可以找到如下錯誤:
Plesk Management service pipe communication error: No process is on the other end of the pipe. (Error code 233) at Unable to write to pipe at (Con::OverlappedPipe::beginWrite line 358). Trying to reconnect.
3. 在 IIS > Sites > SmarterMail > Bindings 中,SmarterMail只綁定到 localhost。
4. 嘗試通過 http://127.0.0.1:9998 訪問SmarterMail界面時,出現(xiàn)錯誤請求 (Bad Request) 錯誤。
原因
SmarterMail不監(jiān)聽127.0.0.1。
解決方案
1. 通過RDP登錄服務器。
2. 進入 IIS > Sites > SmarterMail > Bindings。
3. 在端口9998上添加綁定而不指定主機名令其監(jiān)聽所有的IP地址,包括 127.0.0.1。
4. 通過命令行執(zhí)行下面的命令:
C:\> services.msc
5. 重啟SmarterMail服務。
6. 進入 工具與設置 > 服務器組件 嘗試再次配置SmarterMail。